#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)звук ([Гг]ав!|[Мм]яу!)"
Local $sString = "звук мяу! " & @CRLF & _
"звук Мяу!" & @CRLF & _
"звук гав!" & @CRLF & _
"звук Гав!" & @CRLF & _
"" & @CRLF & _
""
Local $sSubst = "Если улышал \0 Скажи в ответ: \1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)