package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)звук ([Гг]ав!|[Мм]яу!)`)
var str = `звук мяу!
звук Мяу!
звук гав!
звук Гав!
`
var substitution = "Если улышал \0 Скажи в ответ: \1"
fmt.Println(re.ReplaceAllString(str, substitution))
}