use strict;
my $str = 'звук мяу!
звук Мяу!
звук гав!
звук Гав!
';
my $regex = qr/звук ([Гг]ав!|[Мм]яу!)/mp;
my $subst = 'Если улышал \\0 Скажи в ответ: \\1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";