using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"звук ([Гг]ав!|[Мм]яу!)";
string substitution = @"Если улышал \0 Скажи в ответ: \1";
string input = @"звук мяу!
звук Мяу!
звук гав!
звук Гав!
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}