import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "звук ([Гг]ав!|[Мм]яу!)";
final String string = "звук мяу! \n"
+ "звук Мяу!\n"
+ "звук гав!\n"
+ "звук Гав!\n\n";
final String subst = "Если улышал \\0 Скажи в ответ: \\1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}