import re
regex = re.compile(r"звук ([Гг]ав!|[Мм]яу!)", flags=re.MULTILINE)
test_str = ("звук мяу! \n"
"звук Мяу!\n"
"звук гав!\n"
"звук Гав!\n\n")
subst = "Если улышал \\0 Скажи в ответ: \\1"
result = regex.sub(subst, test_str)
if result:
print(result)