# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^\d{5}\t[cC] .*$(*SKIP)(*FAIL)|\h{2,}/ /gm;t' <<< "01090 C -------CALCULATION OF SOMETHING--
01100 \"SOME.VARIABLE\" = \"SOME.OTHER.VARIABLE\" + 2
01110 IF(\"SOME.VARIABLE\" .NE. \"SOME.VALUE\") THEN ON(\"SOME.MACHINE\")"