#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^\d{5}\t[cC] .*$(*SKIP)(*FAIL)|\h{2,}"
Local $sString = "01090 C -------CALCULATION OF SOMETHING--" & @CRLF & _
"" & @CRLF & _
"01100 "SOME.VARIABLE" = "SOME.OTHER.VARIABLE" + 2" & @CRLF & _
"" & @CRLF & _
"01110 IF("SOME.VARIABLE" .NE. "SOME.VALUE") THEN ON("SOME.MACHINE")"
Local $sSubst = " "
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)