// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^\d{5}\t[cC] .*$(*SKIP)(*FAIL)|\h{2,}").unwrap();
let string = "01090 C -------CALCULATION OF SOMETHING--
01100 \"SOME.VARIABLE\" = \"SOME.OTHER.VARIABLE\" + 2
01110 IF(\"SOME.VARIABLE\" .NE. \"SOME.VALUE\") THEN ON(\"SOME.MACHINE\")";
let substitution = " ";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}