# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^\d{5}\t[cC] .*$(*SKIP)(*FAIL)|\h{2,}"
test_str = ("01090 C -------CALCULATION OF SOMETHING--\n\n"
"01100 \"SOME.VARIABLE\" = \"SOME.OTHER.VARIABLE\" + 2\n\n"
"01110 IF(\"SOME.VARIABLE\" .NE. \"SOME.VALUE\") THEN ON(\"SOME.MACHINE\")")
subst = " "
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.