using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\d{5}\t[cC] .*$(*SKIP)(*FAIL)|\h{2,}";
string substitution = @" ";
string input = @"01090 C -------CALCULATION OF SOMETHING--
01100 ""SOME.VARIABLE"" = ""SOME.OTHER.VARIABLE"" + 2
01110 IF(""SOME.VARIABLE"" .NE. ""SOME.VALUE"") THEN ON(""SOME.MACHINE"")";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}