import Foundation
let pattern = #"^\d{5}\t[cC] .*$(*SKIP)(*FAIL)|\h{2,}"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
01090 C -------CALCULATION OF SOMETHING--
01100 "SOME.VARIABLE" = "SOME.OTHER.VARIABLE" + 2
01110 IF("SOME.VARIABLE" .NE. "SOME.VALUE") THEN ON("SOME.MACHINE")
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #" "#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)