package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\d{5}\t[cC] .*$(*SKIP)(*FAIL)|\h{2,}`)
var str = `01090 C -------CALCULATION OF SOMETHING--
01100 "SOME.VARIABLE" = "SOME.OTHER.VARIABLE" + 2
01110 IF("SOME.VARIABLE" .NE. "SOME.VALUE") THEN ON("SOME.MACHINE")`
var substitution = " "
fmt.Println(re.ReplaceAllString(str, substitution))
}