# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/<([^ ?]+).*>((?=[^<]*• )[\w\W]+)<\\/(\1)>/<ul>\2<\/ul>/gm;t' <<< "<p class=\"bodytext\">
• This is some random text.<br>
• This is some other random text.<br>
• This is another random text.
</p>"