$re = '/<([^ ?]+).*>((?=[^<]*• )[\w\W]+)<\/(\1)>/m';
$str = '<p class="bodytext">
• This is some random text.<br>
• This is some other random text.<br>
• This is another random text.
</p>';
$subst = "<ul>\2</ul>";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;