import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<([^ ?]+).*>((?=[^<]*• )[\\w\\W]+)<\\/(\\1)>";
final String string = "<p class=\"bodytext\">\n"
+ " • This is some random text.<br>\n"
+ " • This is some other random text.<br>\n"
+ " • This is another random text.\n"
+ "</p>";
final String subst = "<ul>\\2</ul>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}