import re
regex = re.compile(r"<([^ ?]+).*>((?=[^<]*• )[\w\W]+)<\/(\1)>", flags=re.MULTILINE)
test_str = ("<p class=\"bodytext\">\n"
" • This is some random text.<br>\n"
" • This is some other random text.<br>\n"
" • This is another random text.\n"
"</p>")
subst = "<ul>\\2</ul>"
result = regex.sub(subst, test_str)
if result:
print(result)