use strict;
my $str = '<p class="bodytext">
• This is some random text.<br>
• This is some other random text.<br>
• This is another random text.
</p>';
my $regex = qr/<([^ ?]+).*>((?=[^<]*• )[\w\W]+)<\/(\1)>/mp;
my $subst = '<ul>\\2</ul>';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";