using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(.+?),\s\d{6},\s(\d{1,2}\.\d+),\s(\d{1,2}\.\d+)";
string input = @"Богоявленский пер., 3с2, Москва, Россия, 109012, 55.75658286166606, 37.62422561645508
";
RegexOptions options = RegexOptions.CultureInvariant | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}