re = /(.+?),\s\d{6},\s(\d{1,2}\.\d+),\s(\d{1,2}\.\d+)/i
str = 'Богоявленский пер., 3с2, Москва, Россия, 109012, 55.75658286166606, 37.62422561645508
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end