const regex = /(.+?),\s\d{6},\s(\d{1,2}\.\d+),\s(\d{1,2}\.\d+)/gui;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(.+?),\\s\\d{6},\\s(\\d{1,2}\\.\\d+),\\s(\\d{1,2}\\.\\d+)', 'gui')
const str = `Богоявленский пер., 3с2, Москва, Россия, 109012, 55.75658286166606, 37.62422561645508
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}