package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)(.+?),\s\d{6},\s(\d{1,2}\.\d+),\s(\d{1,2}\.\d+)`)
var str = `Богоявленский пер., 3с2, Москва, Россия, 109012, 55.75658286166606, 37.62422561645508
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}