import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(.+?),\\s\\d{6},\\s(\\d{1,2}\\.\\d+),\\s(\\d{1,2}\\.\\d+)";
final String string = "Богоявленский пер., 3с2, Москва, Россия, 109012, 55.75658286166606, 37.62422561645508\n";
final Pattern pattern = Pattern.compile(regex, Pattern.UNICODE_CASE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}