$re = '/(.+?),\s\d{6},\s(\d{1,2}\.\d+),\s(\d{1,2}\.\d+)/ui';
$str = 'Богоявленский пер., 3с2, Москва, Россия, 109012, 55.75658286166606, 37.62422561645508
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);