#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(\w=)\(([^()]+)\)"
Local $sString = "(x=(1.22|2|3) && za=(hello|world|there|wow)||yy=(2|3))"
Local $sSubst = "$1$2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)