re = /(\w=)\(([^()]+)\)/m
str = '(x=(1.22|2|3) && za=(hello|world|there|wow)||yy=(2|3))'
subst = '$1$2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result