// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(\w=)\(([^()]+)\)").unwrap();
let string = "(x=(1.22|2|3) && za=(hello|world|there|wow)||yy=(2|3))";
let substitution = "$1$2";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}