package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\w=)\(([^()]+)\)`)
var str = `(x=(1.22|2|3) && za=(hello|world|there|wow)||yy=(2|3))`
var substitution = "$1$2"
fmt.Println(re.ReplaceAllString(str, substitution))
}