using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\w=)\(([^()]+)\)";
string substitution = @"$1$2";
string input = @"(x=(1.22|2|3) && za=(hello|world|there|wow)||yy=(2|3))";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}