const regex = /(\w=)\(([^()]+)\)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\w=)\\(([^()]+)\\)', 'gm')
const str = `(x=(1.22|2|3) && za=(hello|world|there|wow)||yy=(2|3))`;
const subst = `$1$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);