use strict;
my $str = '(x=(1.22|2|3) && za=(hello|world|there|wow)||yy=(2|3))';
my $regex = qr/(\w=)\(([^()]+)\)/mp;
my $subst = '$1$2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";