# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\d{2}h\d{0,2})/<br>\1/g;t' <<< "\"programacao\": \"11h Abertura – Som Mecânico 12h30 Lino e Orquestra 15h30 Volkstanzgruppe Blauer Berg - Timbó - SC (Infanto Juvenil) 15h45"