using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\d{2}h\d{0,2})";
string substitution = @"<br>\1";
string input = @"""programacao"": ""11h Abertura – Som Mecânico 12h30 Lino e Orquestra 15h30 Volkstanzgruppe Blauer Berg - Timbó - SC (Infanto Juvenil) 15h45";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}