$re = '/(\d{2}h\d{0,2})/';
$str = '"programacao": "11h Abertura – Som Mecânico 12h30 Lino e Orquestra 15h30 Volkstanzgruppe Blauer Berg - Timbó - SC (Infanto Juvenil) 15h45';
$subst = "<br>\1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;