package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\d{2}h\d{0,2})`)
var str = `"programacao": "11h Abertura – Som Mecânico 12h30 Lino e Orquestra 15h30 Volkstanzgruppe Blauer Berg - Timbó - SC (Infanto Juvenil) 15h45`
var substitution = "<br>\1"
fmt.Println(re.ReplaceAllString(str, substitution))
}