import Foundation
let pattern = #"(\d{2}h\d{0,2})"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #""programacao": "11h Abertura – Som Mecânico 12h30 Lino e Orquestra 15h30 Volkstanzgruppe Blauer Berg - Timbó - SC (Infanto Juvenil) 15h45"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"<br>\1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)