const regex = /(\d{2}h\d{0,2})/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\d{2}h\\d{0,2})', 'g')
const str = `"programacao": "11h Abertura – Som Mecânico 12h30 Lino e Orquestra 15h30 Volkstanzgruppe Blauer Berg - Timbó - SC (Infanto Juvenil) 15h45`;
const subst = `<br>\1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);