#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^([0-9])+[_]"
Local $sString = "01_Start" & @CRLF & _
"02_First" & @CRLF & _
"03_Second" & @CRLF & _
"04_Third"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)