re = /^([0-9])+[_]/m
str = '01_Start
02_First
03_Second
04_Third'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result