import re
regex = re.compile(r"^([0-9])+[_]", flags=re.MULTILINE)
test_str = ("01_Start\n"
"02_First\n"
"03_Second\n"
"04_Third")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)