const regex = /^([0-9])+[_]/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^([0-9])+[_]', 'gm')
const str = `01_Start
02_First
03_Second
04_Third`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);