use strict;
my $str = '01_Start
02_First
03_Second
04_Third';
my $regex = qr/^([0-9])+[_]/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";