$re = '/^([0-9])+[_]/m';
$str = '01_Start
02_First
03_Second
04_Third';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;