#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)fruit_id "([^"]*)"; salad_id "";"
Local $sString = "fruit_id "Apple"; salad_id ""; " & @CRLF & _
"fruit_id "Mango"; salad_id "";" & @CRLF & _
"fruit_id "Kiwi"; salad_id ""; "
Local $sSubst = "fruit_id "\1"; salad_id "\1";"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)