import Foundation
let pattern = #"fruit_id "([^"]*)"; salad_id "";"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
fruit_id "Apple"; salad_id "";
fruit_id "Mango"; salad_id "";
fruit_id "Kiwi"; salad_id "";
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"fruit_id "\1"; salad_id "\1";"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)