package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)fruit_id "([^"]*)"; salad_id "";`)
var str = `fruit_id "Apple"; salad_id "";
fruit_id "Mango"; salad_id "";
fruit_id "Kiwi"; salad_id ""; `
var substitution = "fruit_id "\1"; salad_id "\1";"
fmt.Println(re.ReplaceAllString(str, substitution))
}