const regex = /fruit_id "([^"]*)"; salad_id "";/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('fruit_id "([^"]*)"; salad_id "";', 'gm')
const str = `fruit_id "Apple"; salad_id "";
fruit_id "Mango"; salad_id "";
fruit_id "Kiwi"; salad_id ""; `;
const subst = `fruit_id "\1"; salad_id "\1";`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);