$re = '/fruit_id "([^"]*)"; salad_id "";/m';
$str = 'fruit_id "Apple"; salad_id "";
fruit_id "Mango"; salad_id "";
fruit_id "Kiwi"; salad_id ""; ';
$subst = "fruit_id \"\1\"; salad_id \"\1\";";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;