import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "fruit_id \"([^\"]*)\"; salad_id \"\";";
final String string = "fruit_id \"Apple\"; salad_id \"\"; \n"
+ "fruit_id \"Mango\"; salad_id \"\";\n"
+ "fruit_id \"Kiwi\"; salad_id \"\"; ";
final String subst = "fruit_id \"\\1\"; salad_id \"\\1\";";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}