using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(RR|IR|US|BUG|VUL)(\d{13,14})|(TX|WI|DTS)(\d{13})|(DTS[a-zA-Z0-9]{19})|(SR)(\d{14})|(#)(\d+)";
string input = @"RR1234567890120";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}